Ruby 1.9.3 wechselt zur BSD-Lizenz

02.11.2011

Neben technischen Änderungen bringt die neueste Version des Ruby-Interpreters einen Wechsel der Lizenz mit sich.

Die neueste Version 1.9.3 des Interpreters für die Skriptsprache Ruby beschert den Anwendern einige Verbesserungen. Beispielsweise lädt er nun Erweiterungsbibliotheken schneller. Das Locking in Skriptprogrammen mit mehreren Threads wurde ebenfalls verbessert. Darüber hinaus wurde eine große Zahl von Modulen und Funktionen aktualisiert, über die das NEWS-Dokument des neuen Release mehr verrät.

Beginnend mit der Version 1.9.3 ist Ruby erstmals nicht mehr dual unter der Ruby- und der GPL lizenziert, sondern unter der Ruby- und einer BSD-Lizenz. Ein Grund für den Wechsel war die Änderung der Lizenz der Readline-Bibliothek zur GPLv3, die inkompatibel zu einer Reihe anderer Lizenzen, darunter der GPLv2 ist. Eine Diskussion im Ruby-Bugtracker liefert ausführliche Hintergrundinformationen dazu.

Ähnliche Artikel

Artikel der Woche

Eigene Registry für Docker-Images

Wer selber Docker-Images herstellt, braucht auch eine eigene Registry. Diese gibt es ebenfalls als Docker-Image, aber nur mit eingeschränkter Funktionalität. Mit einem Auth-Server wird daraus ein brauchbares Repository für Images. (mehr)
Einmal pro Woche aktuelle News, kostenlose Artikel und nützliche ADMIN-Tipps.
Ich habe die Datenschutzerklärung gelesen und bin einverstanden.

Konfigurationsmanagement

Ich konfiguriere meine Server

  • von Hand
  • mit eigenen Skripts
  • mit Puppet
  • mit Ansible
  • mit Saltstack
  • mit Chef
  • mit CFengine
  • mit dem Nix-System
  • mit Containern
  • mit anderer Konfigurationsmanagement-Software

Google+

Ausgabe /2019